Mikrotik: RouterOS v6.10 rilasciato

Il 12 febbraio 2014 Mikrotik ha rilasciato la versione 6.10 del suo sistema operativo per router (RouterOS), le nuove funzionalità aggiunge/rimosse sono:

**KNOWN ISSUE: IPsec AES-CBC 256 Bit encryption algorithm doesn’t work in some cases. Use 128 bit

  • AES, or hold on for v6.11**
  • fix autosupout.rif generation after kernel panic;
  • ovpn – make it work again;
  • ovpn client – remove cipher=any & auth=any options, protocol does not support them;
  • pptp – fixed where Windows & MacOS clients were disconnecting all the time;
  • sstp – make it work with Windows client with AES encryption;
  • ipv6 pool – fix dynamic prefix disappearing which may influence large VPNs with IPv6;
  • ssh client – fix key agreement when sometimes wrong DH algorithm was selected;
  • bgp – multipath eBGP now does not propagate BGP nexthop unless forced in configuration;
  • removed 10/100 half duplex from autonegotiation advertisement on CCR;

L’aggiornamento è scaricabile gratuitamente, se la licenza in possesso lo consente, dal seguente link (http://www.mikrotik.com/download).

Server piantato su “UEFI platform initialization”

Ieri ho avuto un problema singolare con un server IBM x3400 M2 (7837), in seguito a un riavvio programmato il server si è piantato subito dopo l’accensione con un generico messaggio in dos:

UEFI platform initialization

e da li non c’è stato verso di smuoverlo.

Dopo aver aperto una chiamata alla IBM Italia, ieri pomeriggio, questa mattina verso le 13:00 si è presentato il tecnico, che passato l’imbarazzo iniziale per via del server recente che non conosceva e dopo un’attenta analisi del problema propone di cambiare la motherboard visto che il sistema non effettua neanche il boot e quindi non è possibile ricaricare il firmware.

Suggerisco quindi di staccare la batteria tampone e lasciare il server scollegato dall’alimentazione per qualche minuto. Chissà magari un reset del CMOS avrebbe risolto il problema. E così abbiamo fatto.

Il caso ha voluto che questo metodo fosse risolutivo. Probabilmente un bug nel modulo UEFI (una sorta di BIOS delle macchine IBM) lo ha mandato in loop.